Welcome, Friend!

It looks like you're new here. If you want to get involved, click one of these buttons!

Veritas-Health LLC has recently released patient forums to our Arthritis-Health web site.

Please visit http://www.arthritis-health.com/forum

There are several patient story videos on Spine-Health that talk about Arthritis. Search on Patient stories
Protect anonymity
We strongly suggest that members do not include their email addresses. Once that is published , your email address is available to anyone on the internet , including hackers.

All discussions and comments that contain an external URL will be automatically moved to the spam queue. No external URL pointing to a medical web site is permitted. Forum rules also indicate that you need prior moderator approval. If you are going to post an external URL, contact one of the moderators to get their approval.
Attention New Members
Your initial discussion or comment automatically is sent to a moderator's approval queue before it can be published.
There are no medical professionals on this forum side of the site. Therefore, no one is capable or permitted to provide any type of medical advice.
This includes any analysis, interpretation, or advice based on any diagnostic test

Having an x-stop for 7 years and now I'm feeling like I've had nothing.. Isn't it still working? Hel

Joy64JJoy64 Posts: 2
edited 11/23/2014 - 11:23 AM in Spinal Stenosis
I had the x-stop procedure done in 2007 and yes I st had some pain but it was not that bad as before... Then I gained weight which when my dr. Saw this I had to lose which I did.. Now here's 7 years later and now I've got this extra back pain which I've had a mri done and it's my s1 starting to pain too.. Has the x-stop quit working, has scare tissue grown over it or what's going on??? I'm worried I'm gonna need more back surgery...? Any comments are welcome I'm new to this forum..! Help....


Sign In or Register to comment.